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1 Analysis workflow

The schematic diagram of the data analysis steps that have been performed is shown in figure 1.

Figure 1: Metagenome Analysis v2.3 Workflow
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2 Samples Analysed

Sample2, sample1.

3 Reference Database

Table 1: Taxonomic Profiling database composition (Metaphlan2).

Kingdom Organisms Sequences Source

Archaea 292 311 NCBI Genomes (complete)
Bacteria 6,084 11,585 NCBI Genomes (complete)
Fungi 277 45,331 NCBI Genomes (complete + contigs)
Virus 10,212 13,701 NCBI Genomes (complete)

Table 2: Taxonomic Profiling database composition (KrakenUniq).

Kingdom Organisms Sequences Source

Archaea 258 6,323 NCBI Genomes (complete)
Bacteria 5,550 303,145 NCBI Genomes (complete)
Fungi 245 171,704 NCBI Genomes (complete + contigs)
Protozoa 75 363,606 NCBI Genomes (complete + contigs)
Virus 9,201 11,876 NCBI Genomes (complete)

Table 3: IGC database (Integrated Gene Catalog of the human gut microbiome) [1].

Tag Description

Name IGC
Release Mar. 2014
Genes (Million) 9.88
% Complete ORFs 57.74 %
Total length (Mbp) 7,436
Average length (bp) 753
N50 (bp) 1,035
N90 (bp) 384
Max length (bp) 88,230
Min length (bp) 100
% annotated on Phylum level 21.30 %
% annotated on Genus level 16.30 %
% annotated on KEGG 42.10 %
% annotated on eggNOG 60.40 %
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Table 4: Mvir database of known toxins, virulence factors, and antibiotic resistance genes [2].

Tag Description

Name MvirDB
Release Dec. 2015
Total sequences 26,373
Longest (bp) 198,867
Smallest (bp) 17
Mean (bp) 1,188
Median (bp) 798

© Eurofins Genomics Europe Sequencing GmbH 3 / 26



Analysis Report 20210527 EF-Demo

4 Results

4.1 Sequence Quality Metrics

The base quality of each sequence read is inspected. Low quality calls are removed before proceeding with
further processing. Using a sliding window approach, bases with low quality are removed from the 3’ and 5’
ends. Bases are removed if the average phred quality is below 15. Finally only mate pairs (forward and reverse
read) were used for the next analysis step. The total amount of raw sequence data and the results of the
quality filtering is collected and reported in the following table.

Table 5: Sequence quality metrics per sample

Sample Total Reads LQ Reads Single Reads HQ Reads

Sample2 44,215,290 1,317,449 (3.0%) 673,865 (1.5%) 42,223,976 (95.5%)
sample1 42,714,088 1,583,424 (3.7%) 814,862 (1.9%) 40,315,802 (94.4%)

Total Reads: Total number of sequence reads analysed for each sample.

LQ Reads: Number (percentage) of low quality reads.

Single Reads: High quality reads without mates (2nd read). These are not included for further analysis.

HQ Reads: Number (percentage) of high quality reads used for further analysis.

4.2 Taxonomic profiling

After screening and removing host sequence reads, non-host reads are subjected to taxonomic profiling algo-
rithm. Taxonomic profiling is done using Metaphlan2[3].

Uclassified reads are than subjected to KrakenUniq[4]. Kraken[5] classifies reads by breaking each into over-
lapping k-mers. Each k-mer is mapped to the lowest common ancestor (LCA) of the genomes containing
that k-mer in a precomputed reference database. For each read, a classification tree is found by pruning the
taxonomy and only retaining taxa (including ancestors) associated with k-mers in that read. Each node is
weighted by the number of k-mers mapped to the node, and the path from root to leaf with the highest sum
of weights is used to classify the read. KrakenUniq computes the number of unique k-mers observed for each
taxon, which allows to filter more false positives. Filters applied are listed in table ??. The final classified,
unclassified and filter passed reads are reported in table 6.

Table 6: Taxonomic Profiling metrics per sample.

Sample Name Reads Classified Unclassified

Sample2 42,223,976 14,802,779 (35.06 %) 27,421,197 (64.94 %)
sample1 40,315,802 16,378,043 (40.62 %) 23,937,759 (59.38 %)
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Table 7: Number of reads assigned to different kingdoms for Sample2, sample1.

Kingdom Sample2 sample1

Archaea 4,826 0.03 % 6,444 0.04 %
Bacteria 14,731,766 99.52 % 16,292,751 99.48 %
Eukaryota 1,592 0.01 % 1,304 0.01 %
Fungi 6,414 0.04 % 4,778 0.03 %
Viruses 33,764 0.23 % 47,996 0.29 %
Ambiguous 24,416 0.16 % 24,768 0.15 %

Ambigious: Reads which can not be assigned to one specific kingdom.

Eukaryota: Parasitic and non-parasitic Protozoa.
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4.2.1 Taxa abundance

Read counts of input samples observed at various taxa levels (Phylum, Genus, and Species) are collected
and normalized by using the rarefy function implemented in the vegan bioconductor package[6] to com-
pare species richness from all samples in the analysis run. Rarefied read counts enable better comparisons
of OTU profiles between samples with different sample sizes. The final read counts in the tables (Taxa-
level.composition.reads.normalized.tsv) contain normalized / rarefied read counts. The corresponding raw
read counts are in Taxa-level.composition.reads.raw.tsv.

Abundance measured by the percentage of OTU assigned reads from various taxonomic levels is determined
and are used to generate heatmaps and bar plots at Phylum, Genus and Species levels.

The measured abundance levels are in OTU distribution tables (Taxa-level.composition.tsv). Heatmap and
bar plots representing the taxonomic abundance at various levels are in OTU abundance heatmap (Taxa-
level.rarefaction heatmap.png) and OTU distribution plots (Taxa-level.barplot.png), respectively.
Possible reasons for missing plots -

Figure 2: Heat map(s) showing the taxonomic abundance and their relation across the samples.
Dendrograms determined by computing hierarchical clustering from the abundance levels shows the
relationship between the species (left) and the samples (top). The abundance levels (number of reads
associated with each taxa) are logarithmically transformed to base 2 for clarity. Taxa-level: Species

i) only one sample in the analysis

ii) missing data

iii) selected parameters are too stringent
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Figure 3: Bar plot(s) showing the taxonomic abundance across the samples. Taxa-level: Species

Possible reasons for missing plots -

i) only one sample in the analysis

ii) missing data

iii) selected parameters are too stringent
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4.2.2 Species diversity

A diversity index is a quantitative measure that reflects how many different types (such as species) are in
a dataset, and simultaneously takes into account how evenly the basic entities (such as individuals) are dis-
tributed among those types. The value of a diversity index increases both when the number of species increases
and when all species are present at nearly the same level. For a given number of species, the value of a diversity
index is maximized when all species are equally abundant.

The following diversity indices are computed using vegan[6] package in R.
Simpson refers to Simpson diversity index and has values ranging from 0 to 1. Values near 1 are simple
environments and smaller values are diverse environments.
InvSimpson refers to inverse Simpson diversity and has values >0. A larger value means greater diversity.
Shannon refers to Shannon diversity index and has values >0. A higher value means greater diversity.
Alpha refers to Fischer’s model of predicting species richness by computing alpha diversity and has values >0.
A larger value means greater diversity.
Evenness refers to the distribution of individuals across species and is determined by Pielou’s measure of species
evenness. The index tends to 0 as the evenness decreases in simple environments (species-poor communities).
SpeciesNo refers to the absolute number of species found in each sample.

Figure 4: Various diversity indices computed based on the species counts found in each sample.
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4.2.3 Rarefaction curves

Rarefaction allows the calculation of species richness for a given number of individual samples, based on the
construction of rarefaction curves. This curve is a plot of the total number of distinct species found as a
function of the number of sequences sampled. Sampling curves generally rise very quickly at first and then
level off towards an asymptote as fewer new species are found in each sample. These rarefaction curves are
calculated from the table of species abundance. The curves represent the average number of different species
found for subsamples of the complete dataset.

Figure 5: Rarefaction curve of annotated species richness.
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4.2.4 Interactive plots

Taxonomic profiling results produced by KrakenUniq[4] are used to generate interactive plots using Krona[7].
Krona is a visualization tool that allows intuitive exploration of relative abundances and confidences within
the complex hierarchies of metagenomic classifications.

Figure 6: Example of an interactive plot generated by Krona (interactive plots.html).
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4.3 Functional profiling

Non-host sequence reads are mapped against a reference dataset - the integrated reference catalog (IGC[1])
using Bowtie[8] with default parameters. IGC contains high quality reference genes identified in the human
microbiome project (http://commonfund.nih.gov/hmp/overview).
Reads that could be associated to IGC gene sets are recorded in table 8. IGC associated reads are further
filtered to include only reads that could be placed uniquely and have both reads in a pair. High quality IGC
associated reads are annotated, consolidated and reported.

Table 8: Functional Profiling metrics per sample

Sample Name Reads Mapped Reads

Sample2 41,741,414 4,073,777 (9.76%)
sample1 39,805,788 5,812,462 (14.60%)

The alignment classification table includes the following read categories:

• Mapped: Reads mapped to reference.

• Unique: Reads mapped to exactly one site on the reference.

• Non-unique: Reads mapped to more than one site on the reference.

• Singletons: Reads with itself mapped and its mate unmapped.

• Cross-Contig: Reads with the other end mapped to a different site.

Percentage of reads in category Unique is calculated based on the number of reads mapping to entire reference.

Table 9: Read metrics for Sample2, sample1.

Read category Sample2 sample1

Mapped 4,073,777 5,812,462
Unique 2,405,703 (59.05%) 3,205,435 (55.15%)
Non-unique 1,668,074 (40.95%) 2,607,027 (44.85%)
Singletons 660,863 (16.22%) 793,612 (13.65%)
Cross-Contig 362,176 (8.89%) 364,946 (6.28%)

IGC associated reads are consolidated based on the Kyoto Encyclopedia of Genes and Genomes (KEGG)[9]
functional annotations. KEGG is a database resource for understanding high-level functions and utilities of a
biological system, such as the cell, the organism and the ecosystem, from molecular-level information, espe-
cially large-scale molecular datasets generated by genome sequencing and other high-throughput technologies.

The composition of various functional categories for each sample is summarized in the following table and
figures.
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Table 10: Composition of top 20 functional categories for all sample(s)
(KEGG ANNOTATION.composition.top hits.tsv

FUNCTION Sample2 sample1
unknown 33.40 33.48
Carbohydrate Metabolism 8.03 8.02
Cellular Processes and Signaling 6.53 6.46
Genetic Information Processing 5.57 5.48
Membrane Transport 5.44 5.49
Poorly Characterized 5.39 5.37
Metabolism 5.22 5.20
Replication and Repair 4.69 4.69
Amino Acid Metabolism 4.64 4.64
Nucleotide Metabolism 3.06 3.05
Enzyme Families 2.58 2.57
Energy Metabolism 2.37 2.35
Translation 2.04 2.09
Transcription 1.90 1.90
Folding, Sorting and Degradation 1.76 1.76
Metabolism of Cofactors and Vitamins 1.68 1.70
Glycan Biosynthesis and Metabolism 1.34 1.31
Signal Transduction 1.25 1.25
Lipid Metabolism 1.11 1.10
Metabolism of Terpenoids and Polyketides 0.52 0.53

Figure 7: Bar plot showing the relative number of genes found in the most highly represented functional
categories for all samples.
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Figure 8: Heat map showing the frequency of the most highly represented functional categories and their
relation across the samples. Dendrograms determined by computing hierarchical clustering from the
frequencies shows the relationship between the various functional categories (left) and the samples (top).
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Figure 9: Correlation plot showing the relationship between the samples based on the identified functional
profiles of the respective samples. Values close to +1 indicate a high degree of positive correlation between
the sample pair, whereas values close to -1 indicate a high degree of negative correlation between the sample
pair in comparison. Values close to zero indicate poor correlation of either kind, and 0 indicates no
correlation at all.
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4.4 Resistance screening

Non-host sequence reads are mapped against a resistance gene dataset - the microbial virulence database
(MvirDB[2]) using Bowtie[8] with default parameters. MvirDB is a collection of genes known to have virulence
properties like antibiotic resistance, pathogenicity island, resistance protein and transcription factors http:

//nar.oxfordjournals.org/content/35/suppl_1/D391.full.
Reads mapping to MvirDB are recorded in table 11. Virulence associated reads are further filtered to include
only reads that could be placed uniquely and have both reads of a pair. High quality virulence associated reads
are annotated, consolidated and reported.

Table 11: Resistance screening metrics per sample

Sample Name Reads Mapped Reads

Sample2 41,741,414 78,238 (0.19%)
sample1 39,805,788 89,000 (0.22%)

The alignment classification table includes the following read categories:

• Mapped: Reads mapped to reference.

• Unique: Reads mapped to exactly one site on the reference.

• Non-unique: Reads mapped to more than one site on the reference.

• Singletons: Reads with itself mapped and its mate unmapped.

• Cross-Contig: Reads with the other end mapped to a different site.

Percentage of reads in category Unique is calculated based on the number of reads mapping to entire reference.

Table 12: Read metrics for Sample2, sample1.

Read category Sample2 sample1

Mapped 78,238 89,000
Unique 41,021 (52.43%) 42,840 (48.13%)
Non-unique 37,217 (47.57%) 46,160 (51.87%)
Singletons 19,496 (24.92%) 18,064 (20.30%)
Cross-Contig 2,326 (2.97%) 2,116 (2.38%)

Read distribution on various virulence factors for each sample is summarized in the following table and figure.

Table 13: Distribution of virulence factors for all sample(s) (VIRULENCE.reads.tsv)

Virulence Factor Type Sample2 sample1
antibiotic resistance 13258 15028
pathogenicity island 18480 20384
transcription factor 246 364
virulence protein 1370 1538

© Eurofins Genomics Europe Sequencing GmbH 15 / 26

http://nar.oxfordjournals.org/content/35/suppl_1/D391.full
http://nar.oxfordjournals.org/content/35/suppl_1/D391.full


Analysis Report 20210527 EF-Demo

Figure 10: Sample-wise read distribution of various virulence factors.

© Eurofins Genomics Europe Sequencing GmbH 16 / 26



Analysis Report 20210527 EF-Demo

T
ab

le
14

:
R

el
at

iv
e

co
m

p
os

it
io

n
of

25
m

os
t

ab
u

n
d

an
tl

y
re

pr
es

en
te

d
vi

ru
le

n
ce

fa
ct

or
s

fo
r

al
l

sa
m

p
le

(s
)

(V
IR

U
L

E
N

C
E

.a
n

n
ot

at
io

n
.fi

lt
er

ed
.r

ep
or

t.
ts

v)
VirulenceFactorType

GeneNames

ShortDescription

Sample2

sample1

p
at

h
og

en
ic

it
y

is
la

n
d

X
fa

67
G

tR
N

A
32

(G
ly

ci
n

e)
of

(.
..

)
7.

54
3.

86
an

ti
b

io
ti

c
re

si
st

an
ce

P
S

E
M

T
P

se
u

d
om

on
as

ae
ru

gi
n

o(
..

.)
6.

42
4.

57
p

at
h

og
en

ic
it

y
is

la
n

d
E

co
34

T
tR

N
A

5
(T

h
re

on
in

e)
o(

..
.)

4.
67

4.
00

an
ti

b
io

ti
c

re
si

st
an

ce
A

A
M

70
49

7|
A

A
M

70
49

7|
A

F
(.

..
)

tr
an

sp
os

as
e

T
n

p
A

[E
s(

..
.)

4.
29

3.
96

p
at

h
og

en
ic

it
y

is
la

n
d

S
ag

n
16

7L
tR

N
A

41
(L

eu
ci

n
e)

of
(.

..
)

3.
50

4.
35

p
at

h
og

en
ic

it
y

is
la

n
d

S
ag

t1
64

L
tR

N
A

44
(L

eu
ci

n
e)

of
(.

..
)

3.
42

4.
13

p
at

h
og

en
ic

it
y

is
la

n
d

E
co

21
R

tR
N

A
8

(A
rg

in
in

e)
of

(.
..

)
3.

43
2.

62
an

ti
b

io
ti

c
re

si
st

an
ce

A
A

G
14

40
2|

A
A

G
14

40
2|

A
F

(.
..

)
p

u
ta

ti
ve

tr
an

sp
os

as
e(

..
.)

3.
02

2.
64

vi
ru

le
n

ce
pr

ot
ei

n
A

A
L

08
44

0|
tr

an
sp

os
as

e(
..

.)
tr

an
sp

os
as

e
T

n
p

A
[S

h
(.

..
)

2.
21

2.
03

an
ti

b
io

ti
c

re
si

st
an

ce
C

A
G

25
42

3|
C

A
G

25
42

3
tr

u
n

ca
te

d
tr

an
sp

os
as

(.
..

)
2.

27
1.

96
p

at
h

og
en

ic
it

y
is

la
n

d
N

P
41

47
93
|N

P
41

47
93

IS
5

tr
an

sp
os

as
e

an
d

(.
..

)
2.

37
1.

82
p

at
h

og
en

ic
it

y
is

la
n

d
N

P
41

50
84
|N

P
41

50
84

IS
5

tr
an

sp
os

as
e

an
d

(.
..

)
2.

31
1.

76
an

ti
b

io
ti

c
re

si
st

an
ce

A
A

R
25

03
4|

A
A

R
25

03
4

T
n

p
A

[E
sc

h
er

ic
h

ia
co

(.
..

)
1.

90
1.

78
an

ti
b

io
ti

c
re

si
st

an
ce

C
A

A
51

17
5|

C
A

A
51

17
5

tr
an

sp
os

as
e

[K
le

b
si

e(
..

.)
1.

32
1.

06
an

ti
b

io
ti

c
re

si
st

an
ce

A
A

A
22

91
1|

A
A

A
22

91
1

p
u

ta
ti

ve
[B

ac
te

ro
id

e(
..

.)
0.

80
1.

39
p

at
h

og
en

ic
it

y
is

la
n

d
B

th
90

F
tR

N
A

40
(P

h
en

yl
al

an
i(

..
.)

0.
82

1.
03

p
at

h
og

en
ic

it
y

is
la

n
d

E
co

c4
8X

tR
N

A
50

(t
m

R
N

A
)

of
C

(.
..

)
0.

75
1.

04
p

at
h

og
en

ic
it

y
is

la
n

d
E

co
c1

05
F

tR
N

A
61

(P
h

en
yl

al
an

i(
..

.)
0.

62
0.

88
p

at
h

og
en

ic
it

y
is

la
n

d
S

ti
c1

34
F

tR
N

A
73

(P
h

en
yl

al
an

i(
..

.)
0.

61
0.

78
an

ti
b

io
ti

c
re

si
st

an
ce

A
A

G
54

07
3|

A
A

G
54

07
3

tr
an

sp
os

as
e

[E
sc

h
er

i(
..

.)
0.

44
0.

74
p

at
h

og
en

ic
it

y
is

la
n

d
E

co
c1

14
S

tR
N

A
25

(S
er

in
e)

of
(.

..
)

0.
45

0.
69

an
ti

b
io

ti
c

re
si

st
an

ce
A

A
R

18
97

8|
A

A
R

18
97

8
tr

an
sp

os
as

e
[K

le
b

si
e(

..
.)

0.
47

0.
64

p
at

h
og

en
ic

it
y

is
la

n
d

B
th

60
K

tR
N

A
36

(L
ys

in
e)

of
(.

..
)

0.
51

0.
60

an
ti

b
io

ti
c

re
si

st
an

ce
A

A
L

02
12

6|
A

A
L

02
12

6
tr

an
sp

os
as

e
[E

sc
h

er
i(

..
.)

0.
38

0.
71

tr
an

sc
ri

p
ti

on
fa

ct
or

S
u

b
N

am
e:

F
u

ll=
R

te
B

p
(.

..
)

S
u

b
N

am
e:

F
u

ll=
R

te
B

p
(.

..
)

0.
45

0.
54

© Eurofins Genomics Europe Sequencing GmbH 17 / 26



Analysis Report 20210527 EF-Demo

Figure 11: Correlation plot showing the relationship between the samples based on the identified functional
profiles of the respective samples. Values close to +1 indicate a high degree of positive correlation between
the sample pair in comparison whereas values close to -1 indicate a high degree of negative correlation
between the sample pair. Values close to zero indicate poor correlation of either kind, and 0 indicates no
correlation at all.
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5 Deliverables

Table 15: List of delivered files, format and recommended programs to access the data.

File Format Program To Open File

All.interactive plots.html HTML Web browser
KEGG ANNOTATION.barplot.png PNG Image viewer
KEGG ANNOTATION.composition.filtered.tsv TSV Spreadsheet Editor
KEGG ANNOTATION.composition.top hits.tsv TSV Spreadsheet Editor
KEGG ANNOTATION.composition.tsv TSV Spreadsheet Editor
KEGG ANNOTATION.correlation.png PNG Image viewer
KEGG ANNOTATION.heatmap.png PNG Image viewer
KEGG ANNOTATION.reads.tsv TSV Spreadsheet Editor
KEGG ANNOTATION.tilemap.labels.png PNG Image viewer
KEGG ANNOTATION.tilemap.png PNG Image viewer
Species.barplot.png PNG Image viewer
Species.composition.proportion.tsv TSV Spreadsheet Editor
Species.composition.reads.normalized.tsv TSV Spreadsheet Editor
Species.composition.reads.raw.tsv TSV Spreadsheet Editor
Species.diversity indices.png PNG Image viewer
Species.diversity indicies.tsv TSV Spreadsheet Editor
Species.rarefaction curve.png PNG Image viewer
Species.rarefaction heatmap.log2scale.png PNG Image viewer
Species.rarefaction heatmap.png PNG Image viewer
VIRULENCE.annotation.filtered.tsv TSV Spreadsheet Editor
VIRULENCE.barplot.log10.png PNG Image viewer
VIRULENCE.barplot.png PNG Image viewer
VIRULENCE.correlation.png PNG Image viewer
VIRULENCE.reads.tsv TSV Spreadsheet Editor
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6 Formats

Table 16: References and descriptions of file format.

Format Description

HTML Standard markup language for creating web pages and web applications
PNG Figure or image in Portable Network Graphics format
TSV Tab separated table style text file. This can be imported into spreadsheet pro-

cessing software like MS OFFICE Excel.
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7 FAQ

Q: How can I open a CSV, TSV, or VCF file in Excel?
A: You can open CSV, TSV, VCF, or any other text file using Excel. Please follow this procedure:

i) Start Excel

ii) Click on the ”File” menu button in the top left corner

iii) Click on the ”Open” menu button in the left menu pane

iv) Click on the dropdown-menu in the bottom right corner of the small window that opens. Initially, it should show
”All Excel files (*.xls; *.xlsx)”.

v) Select the topmost entry ”All files (*.*)”

vi) Navigate to the directory with the text files. They should be visible now.

vii) Open the files and click through the appearing ”Text Import Wizard” dialog (Next, Next, Done).

Depending on the content of the text file you want to import, you might want to change some settings in the ”Text
Import Wizard” dialog. Most often, you want to change the decimal separator. The provided text files use the dot as
decimal separator and comma as thousands separator. Make sure that you set both correctly. To do this, click on the
”Advanced” button in pane 3 of the ”Text Import Wizard” dialog. You can find additional information in this article at
the Microsoft Office support site.

Q: How can I view alignments and variants?
A: A convenient tool to view alignments and variant data is the Integrative Genomics Viewer (IGV) for Unix, MS
Windows, and MacOS X. It can be downloaded and installed locally, or can be run as web-application.

• Before loading alignments or variant data into IGV, the reference genome FASTA file has to be loaded via the
Genomes -> Load Genome from File menu. Make sure that you load the same reference genome FASTA file that
was used during mapping.

• To load alignments into IGV select the BAM files via the File -> Load from File menu. Please note that you need
to zoom-in to about 30kb to see alignments. You can set this visibility range threshold and other displaying and
filtering options via the View -> Preferences -> Alignments menu, or the right-click context menu.

• To load variant data into IGV select the VCF files via the File -> Load from File menu. IGV can color mismatch
bases and InDel positions. Use the right-click context menu to configure this and other displaying and filtering
options. Not all mismatch positions in alignments might have been considered significant by the variant analysis
tool and therefore might not be contained in the variant tracks.

• Please visit the IGV online manual to get more information about loading genomes, viewing alignments, and
viewing variants.
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A Sequence Data Used

Naming convention for FASTQ files:
<project-id> <sample-id> <lib-id> <run-id> <lane-no> <read-no>.fastq.gz

<project-id> the unique identifier of this project.

<sample-id> the sample name as provided by the customer.

<lib-id> a unique identifier of the sequencing library created in the lab. Multiple sequencing libraries
may have been created from the same sample material, depending e.g. on project setup.

<run-id> a unique identifier of the sequencing run that created this file.

<lane-no> a number specifying the lane of the sequencing device used for sequencing.

<read-no> either 1 or 2. For paired-end runs, these numbers identify the associated forward and
reverse read files (mate pairs).

Table 17: Analysed samples.

No. Sample File Name

1 Sample2 EF-Demo Sample2 lib12346 1234 1 1.fastq.gz.gz
EF-Demo Sample2 lib12346 1234 1 2.fastq.gz.gz

2 sample1 EF-Demo sample1 lib12345 1234 1 1.fastq.gz.gz
EF-Demo sample1 lib12345 1234 1 2.fastq.gz.gz
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B Relevant Programs

Table 18: Name, version and description of relevant programs.

Program Version Description

bamtools[10] 2.3.0 BamTools provides a small, but powerful suite of command-line utility
programs for manipulating and querying BAM files for data.

Bowtie[8] 2.3.3.1 Bowtie is a ultrafast, memory-efficient short read aligner. It is based on
Burrows-Wheeler transform algorithm.

KrakenUniq[5,
4]

0.5.3 Kraken is an ultrafast and highly accurate program for assigning taxo-
nomic labels to metagenomic DNA sequences. KrakenUniq adds some
additional functionality - most notably a unique k-mer count using the
HyperLogLog algorithm.

Krona[7] 2.5 Krona allows hierarchical data to be explored with zoomable pie charts.
Metaphlan[3] 2.9.20 MetaPhlAn2 is a computational tool for profiling the composition of

microbial communities (Bacteria, Archaea, Eukaryotes and Viruses) from
metagenomic shotgun sequencing data with species level resolution.

Picard[11] 1.131 Picard is a java-based command-line utilities for processing SAM / BAM
files.

R[12] 3.2.4 R is a programming language and environment for statistical computing.
sambamba[13] 0.6.6 Sambamba is a high performance modern robust and fast tool (and

library), for working with SAM and BAM files.
SAMTools[14] 0.1.18 SAMtools provide various utilities for manipulating alignments in the

SAM format.
Trimmomatic[15] 0.33 Trimmomatic performs a variety of useful trimming tasks for Illumina

paired-end and single-end data.
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C Filter Settings

Table 19: Filters used in postprocessing of taxonomic profiling results.

Filter Value

Top OTUs to include in plots 20
Minimum read count proportion 0.01

Table 20: Filters used in postprocessing of functional profiling, resistance screening results.

Filter Value

Top hits to include in plots 20.00
Minimum composition across samples 0.50
Exclude categories from plots unknown,Poorly Characterized

© Eurofins Genomics Europe Sequencing GmbH 25 / 26



©
E

u
ro

fi
n

s
G

en
om

ic
s

E
u

ro
p

e
S

eq
u

en
ci

n
g

G
m

b
H

,
05

-2
02

1,
K

-1
45

8,
V

er
si

on
3.

27
.3

2

Eurofins Genomics’ products, services and applications reach the best quality and safety levels. They are
carried out under strict QM and QA systems and comply with the following standards:

ISO 17025 Accredited analytical excellence GLP
The gold standard to conduct non-clinical
safety studies

ISO 13485
Oligonucleotides according to medical
devices standard

GCP Pharmacogenomic services for clinical studies

cGMP
Products and testing according to pharma
and biotech requirements

Eurofins Genomics Europe Sequencing GmbH • Jakob-Stadler-Platz 7 • 78467 Constance • Germany
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